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This document describes how to upgrade to the latest version of AwareManager by downloading it from 
the AwareManager website. The person performing this procedure should be proficient in executing MS 
Windows commands and must have master access to all the functions in the AwareManager.  You should 
let all AwareManager users know when you will be upgrading.  They will not be able to use the 
AwareManager until you have finished the upgrade process and installed the new version on their PCs 
(approximately an hour, longer depending on the size of your data file). 

Steps I through VI should be preformed prior to calling Database International Group 

 

Step I: Record the location of your AwareManager library and data files 

1. Open the AwareManager and go to File > About Aware 

2. Click on Details and record: 

 

4.   Data file path:   _______________________ 

3. Application path  _____________________ 
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Step II: Special Note for clients using the Accounting Interface Module 

 Important, before continuing: 

If you are using the Accounting Interface Module with a customized account export report,  

DO NOT DELETE the ‘old’ AwareManager Library File in Step VI.   

Instead, go to Main Menu>Accounting>Accounting Preferences, make sure that Custom is 
selected from the Export File drop down box, and save the change. 

 

 

If you are unsure whether or not you have a custom export format please call Database 
International Group at 1-(617)542-8555. 

 

Step III: Back Up Your AwareManager Data File 

1. Have everyone exit properly from the AwareManager (to exit properly select File> Quit from 
the menu bar).  

2. Make a copy of the data file (refer to Appendix A for instructions on backing up your data 
file). 

 

Step IV: Download the AwareManager Upgrade File 

1. Open your web browser. 

2. Go to the appropriate downloads page and click on AwareManager Upgrade File. 
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3. Your web browser will probably give you the option to open or save the file, select Save. 

4. Save the file to your desktop and accept default file name. 

This process will download an executable file to your local machine, depending on the speed of 
your connection this should take less than three minutes to complete. 

 

Step V: Execute the AwareManager Upgrade File 

1. Find the upgrade .exe file on your desktop. 

2. Double click on it. The upgrade process will automatically commence. 

3. On the Modify, repair or remove program window, select the Repair option and select Next. 
The upgrade will reinstall all program components previously installed for the AwareManager. 

4. You do not have to restart your PC. 

5. The upgrade will also update the standard desktop and start menu shortcuts established for 
the AwareManager. If your computer has non-standard shortcuts, or you want to amend the 
standard ones, see the Quick Reference library for assistance on doing this. 

 

Step VI: Delete the ‘old’ AwareManager Library File 

Delete any library files earlier than the current version in the C:/Aware folder (or in whatever 
folder the AwareManager application is located in). 

 

Step VII: Register the AwareManager 

1. Double click on the AwareManager shortcut on your desktop. 

 

Note:  If you are using the Accounting Interface Module with a customized account export report (see 
Step: II), you will be prompted to select your previous library file (this is the library file that contains this 
report.)   

 

 

 

 

 

Very important:  You must select the .lbr file corresponding to the version you were last on, if you do not 
you will lose your customized account export report. 

 

2. When you run the new version for the first time you will be asked to register the program. You 
will see a screen similar to the one shown below. 
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3. Call Database International Group, Inc. at 617-542-8555 (between 9AM and 6PM Eastern 
Standard Time) for a registration password. 

 

Step VIII: Open your Data File and Proceed with the Automated Conversion 

This step is only required the first time the date file is opened with the new version. 

1. Once you have registered the new version, the change data file window (shown below) may 
open. Use the Change Data File window to select your live data file, on the server. 

2. If the AwareManager automatically opens the Practice data file (the file name is shown to the 
right of the 7 icon in the window title): 

If the Practice data file is open, select the Select Data File button on the Logon window to 
open the Change Data File window. 

Proceed with the following instructions after you have selected the data file 

3. You will see a message that says: “Your data file needs to be modified to work with this 
version of the AwareManager.  You should make sure you have a backup before continuing. 
Do you want to proceed?” If you have made a backup, answer “Yes” (if you have not made a 
backup, answer “No” and make a back up!  Refer to Appendix A for detailed instructions on 
backing up your data file). The modifications to the data file may take a while.  

Note: If you have a large data file you may want to copy the data file to your C:/ drive before 
proceeding with the upgrade process as this will make the modifications run faster. Once you 
have completed the modifications you should copy the data file back to the server and remove 
any copy on the local machine. 

4. When the modification of the data file is finished you will be prompted to log on the 
AwareManager. Log on using your existing staff code and password (you must be assigned 
to the Full Access/Master Access Group). 

5. Once you have logged on the About Aware Screen will appear—it should show the latest 
version number. 

6. If your staff code is set up to check reminders when you log on, the About Aware screen will 
not be displayed. To check that you have the correct version of the AwareManager select 
File> About Aware from the menu bar to display the About Aware screen. 
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Step IX: Install Optional Modules and update Number of Users 

1. Add the Tools Menu to the Menu Bar by selecting Main Menu > Administration > Tools. 

2. If you have purchased any of the optional modules (Email, Preventive Maintenance, 
Accounting Interface), then select Optional Modules from the Tools Menu. Tell the Client 
Services Representative from Database International Group, Inc. the serial number that 
appears on the Optional Modules window and they will provide the password required to 
install the optional modules. 

3. If you have purchased additional users, then select Number of Users from the Tools Menu. 
The Number of Users window will display the current number of licensed users available for 
this data file. If this is correct, then click on the Cancel push button, if you have purchase 
additional users then tell the Client Services Representative from Database International 
Group, Inc. the serial number that appears on the window and they will provide the password 
required to update the number of licensed users. 

 

Step X: Check the Version Number and Update the Full Access User Group 

1. Select Main Menu > Administration > Company Information. 

2. Check that the new Version # is displayed; if it isn’t enter the number only (e.g. for Version 
1070, enter “1070”, not “AM1070”). 

3. Update the FULL ACCESS User Group by temporarily turning off security (Main Menu > 
Administration > Preferences), and selecting the “Check All” button for the FULLACCESS 
User Group (refer to Appendix B for detailed instructions on updating your FULLACCESS 
User Group). 

 

Step XI: Exit from the AwareManager and Test Shortcut 

4. Exit from the AwareManager; select File > Quit from the Menu Bar 

5. Double click on your AwareManager icon and log onto AwareManager. 

 

Step XII: Upgrade the AwareManager at all other machines 

 Instructions on installing AwareManager across a network are available in Appendix C 
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Appendix A 

Instructions for copying your data file 

A) Have each AwareManager user exit from the program by selecting File > Quit. 

B) Open Windows Explorer (right click on the Start button and select Explore). 

C) Locate your data file (normally on the network drive). If you do not know the location of 
your data file: 

i. Open the AwareManager and go to File > About Aware. 

ii. Click on Details in the lower right-hand corner. 

iii. This will display the Data file path (the data file path is suffixed with “.df1”). 

iv. Exit from the AwareManager. 

D) Select Edit > Copy from the Explorer menu bar. 

E) Create a folder on your C:\ drive called “Aware Backups” (select File > New > Folder 
from the Explorer menu bar). 

F) Select Edit > Paste from the Explorer menu bar (this will make a copy of the data file and 
paste it into your Aware Backups folder. 

G) IMMEDIATELY rename the back up copy of your data file by selecting File > Rename 
from the Explorer menu bar. 
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Appendix B 

AwareManager Upgrades often include changes to the menu structure.  It is important that you update 
the FULL ACCESS User Group each time you upgrade.  It is also an appropriate time to review all of your 
User Groups.  

 

1. Log into your data file as a user with "FULL ACCESS". 
 
 
 

2. Temporarily turn off security 
 
a) Select: Main Menu > Administration > 

Preferences  
 
b) Deselect the "Implement Security" 

preference. 
 
 
 
 
 
 
 

 
3. Go to Main Menu > Administration > User Group  
 
 
 

4. Find the FULL ACCESS User Group. 
  

a) Click on the Change icon (key)  
 
b) Click on the “Check All” button. This 

will update all features in the User 
Group.  

 
c) Save by clicking on the checkmark. 

 

 

 

 

 

5. IMPORTANT STEP ... return to the system Preferences: Main Menu > Administration > Preferences 
and select the "Implement Security" preference to reactivate security. 
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Appendix C 

This is an easier alternative to installing the upgrade software on each machine that uses the 
AwareManager and registering each separate installation with Database International Group. First you 
must successfully upgrade and register the new version of AwareManager on at least one machine 
connected to the network. The data file must also have been reorganized to work with the new version of 
the AwareManager. All workstations using the AwareManager should be upgraded at the same time and 
all users must be logged off throughout the upgrade process. 

Begin the process on the machine that has installed the AwareManager program files 

Step I: Create a Folder on the Network Drive 

1. Close all other applications on this machine 

2. Open Windows Explorer (right click from Start button and select Explore). 

3. Locate the folder on the network drive that contains the data file for the AwareManager 
(the date file is suffixed with “.df1”). 

4. Create a subfolder in the Aware folder on the network called Application. Select File > New 
> Folder from the Explorer menu bar). 

 

Step II: Copy the Registered Library files to the Network Drive 

1. Using Windows Explorer locate the Aware folder on the C:\drive with the registered 
AwareManager library and the upgrade executable files. Highlight both files and select Edit > 
Copy. 

2. Locate the new Application folder on the network drive and select Edit > Paste from the 
Explorer menu bar. This process should copy the AwareManager Upgrade and registered 
library files to the new Application folder. 

The next steps are performed on the machine that needs to have the new version installed: 

 

Step III: Run the Upgrade Executable 

1. Copy the upgrade executable file from the network drive to the AwareManager application 
folder (usually C:\Aware) on this machine. 

2. Double click on it. The upgrade process will automatically commence. 

3. On the Modify, repair or remove program window, select the Repair option and select Next. 
The upgrade will reinstall all program components previously installed for the AwareManager. 

4. Do not restart this computer until you have copied the registered library (next step). 

 

Step IV: Copy and run the Upgrade files from the Network Drive 

1. Copy the registered .lbr file from the network drive to the application folder and replace the 
existing file from the Upgrade process, as that file is not registered. 

2. Remove the upgrade executable file from the AwareManager application folder on this 
machine. 

 

Step V: Repeat Steps III and IV on all machines running Aware 

Now you are ready to use the latest version of the AwareManager! 


